WordPress5.2发布要求服务器配置不低于PHP5.6.20与MySQL5.6

05/04/201911:56:09 发表评论 786个阅读者

我们大部分个人网站博客、很多企业的官方网站、自媒体,还有其他类型网站都会采用WordPress程序。

围绕WordPress程序网上提供的免费主题、插件以及技术文档非常多,而且WordPress官方给予非常完善的技术升级支持。

自从WordPress程序5.0版本发布后,WordPress官方策略与原先发生了非常大的变化,比如推出Gutenberg新款编辑器,确实是让用惯了经典编辑器的博主们感觉难以适应。

WordPress程序官方提到必须在2021年的时候,会强制使用Gutenberg编辑器,具体后面是不是可以替换传统编辑器。暂时我们还是可以使用经典编辑器,通过直接在Functions.php文件中加入以下代码实现禁止Gutenberg编辑器。

//禁止Gutenberg编辑器
add_filter('use_block_editor_for_post', '__return_false');remove_action( 'wp_enqueue_scripts', 'wp_common_block_scripts_and_styles' );

WordPress5.2发布要求服务器配置不低于PHP5.6.20与MySQL5.6

在前期一篇文章关于官方即将发布WordPress5.2的文章中写道,WordPress官方有提到在四月底会更新WordPress 5.2版本,且需要PHP最低支持需要5.6.20。

延伸阅读:WordPress 5.2 Beta1发布测试,新增古腾堡编辑器区块管理功能等

服务器配置是低于PHP5.6.20版本的,且后面软件升级之后需要升级的建议提前做好准备升级PHP。

从WordPress 5.1开始,运行低于5.6的PHP版本的用户在其仪表板中有一个通知,其中包含帮助他们更新PHP的信息。

WordPress5.2发布要求服务器配置不低于PHP5.6.20与MySQL5.6

特别注意的是:

如果站点在低于5.6.20的PHP版本上运行,则WordPress更新程序将不会向站点提供WordPress 5.2。

如果尝试手动更新WordPress,该更新将失败。

所以说要继续使用WordPress的最新功能,您必须更新到较新版本的PHP。

WordPress鼓励更新到推荐的PHP 7.3版本。PHP internals,新版本的PHP将有利于提高网站访问速度

官方声明:

WordPress 5.2 is targeted for release at the end of this month, and with it comes an update to the minimum required version of PHP. WordPress will now require a minimum of PHP 5.6.20.

Beginning in WordPress 5.1, users running PHP versions below 5.6 have had a notification in their dashboard that includes information to help them update PHP. Since then, the WordPress stats have shown an increase in users on more recent versions of PHP.

根据WordPress的官方文档中介绍到,最好的是升级至PHP7.3版本。

所以我们需要提前做好准备,检查使用的插件或者主题是否兼容。

不要到时候升级之后出现故障措手不及。对于服务器PHP版本的升级方法有很多办法,比如我们可以重新备份网站,然后重新配置新的WEB环境,或者是可以直接在服务器中安装多PHP版本进行切换。

我们在WordPress官方网站下载最新版程序的时候,有文档已经提到建议的最佳PHP与MYSQL数据库版本,以及推荐的WEB环境支持。

We recommend servers running version 7.3 or greater of PHP and MySQL version 5.6 OR MariaDB version 10.0 or greater. We also recommend either Apache or Nginx as the most robust options for running WordPress, but neither is required.

我们可以看到建议是PHP7.3(最新版本是PHP7.3),以及数据库要求最低是MySQL5.6或者MariaDB 10.0,WEB引擎是Nginx或者是Apache。

这次主要是明确要求PHP的最低版本:

This is the first increase in PHP required version for WordPress since 2010, but may not be the only increase in 2019. The WordPress core team will monitor the adoption of the most recent versions of PHP with an eye towards making PHP 7+ the minimum version towards the end of the year.

这次PHP升级是2010年以来的第一次要求强制升级,在后面会要求PHP7+版本起步,所以如果我们可以的话,建议直接升级到7.0+版本。

从测试看PHP7+性能比较优秀的。

avatar

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: